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1.1 Introduccién

Esta seccion explica como instalar el siguiente software:
- Altera Complete Design Suit
- DE2i-150 Development Board Contents

1.2 Instalacién de Altera

Altera provee las herramientas necesarias para desarrollar hardware y software para Altera FPGAs.
El software Quartus Il serd la herramienta principal para crear proyectos de sistemas embebidos,
el cual se encuentra en un DVD incluido en la caja. También es posible descargar esta aplicacion en
la pagina web de altera:

www.altera.com/download

El kit contiene el CD Quartus Il con una edicién de suscripcién y un editor web. La edicidon web de
Quartus Il no requiere licencia.

Altera Complete Design Suite
Free Package - v12.1
For Windows and Linux

Free package

* Quartus® I Web

1.3 Instalando el contenido del DE2i-150

Para instalar los componentes necesarios para desarrollar en la DE2i-150, es necesario copiar los
contenidos de la carpeta (DE2i-150_SYSTEM_CD) localizada en el DE2i-150 system CD a tu
computadora.



Contenido de al DE2i-150 system CD:

Directory Name
User Manual
Demonstrations

Datasheet

Schematic

Tools

2 INSTALAR EL DRIVER USB-BLASTER

2.1 Introduccion

La tarjeta de desarrollo incluye un circuito USB blaster para programacion FPGA. Para poder
comunicar la computadora huésped vy la tarjeta de desarrollo se requiere instalar de drive USB-
Blaster en la computadora huésped. Antes de comenzar la instalacién, se debe verificar den se
encuentra el driver con el directorio: \<Quartus Il installation directory>\drivers\usb-blaster. Si el
driver USB-Blaster no se encuentra, es necesario que verifique la correcta instalacién del software

Quartus Il.

2.2 Preparando el hardware

Description of Contents
Contains the DE2i-150 documentation
Contains design examples of DE2i-150

Contains the datasheets of the components
on DE2i-150

Contains the schematic of DE2i-150

Contains the design and testing tools for
DE2i-150

Esta seccidn describe la instalacion del driver USB-Blaster.

1. Conecte la computadora huésped a la tarjeta mediante el cable USB en el conector USB (J9) del

DE2i_150



2. Conecte a la corriente la tarjeta DE2i-150.
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2.3 Instalando el USB-Blaster Driver para Windows 7
1. Nuevo hardware encontrado.

Una vez que la tarjeta esté conectada a la corriente y encendida, el sistema operativo deberia
reconocer un nuevo hardware, pero sera incapaz de proceder si no tiene el driver instalado. La
tarjeta DE2i_150 es programada al usar el mecanismo USB_Blaster de Altera. Instala el driver
dirigiéndote al Device Manager y da doble-click en USB-Blaster bajo OTHER devices.



Ble Acson Yiew Heb
LL dlolll 7 lo:

4 3 Altera ASP_TEST
» {% Computer
b g Disk drives
o B Display adapters
b i) DVD/CD-ROM drives
b g IDE ATA/ATAPI controllers
» - @ IEEE 1394 Bus host controllers
b Keyboards
b J4 Mice and other pointing devices
» I& Monitors
b 2 Network adapters

4 [y Other devices
I USB-Blaster

» B Processors

b & Sound,video and game controllers
» G Storage controllers

b M System devices

b @ Universal Serial Bus controllers

2. En la ventana de propiedades de USB-Blaster, da click en Update Driver.



Gened  Drver | Detals

% USB-Blaster

Devica type: Othar devicas
Manufachrer Unknown

Locaton Port_#0005 Hub_R0004

Device status

[The drevers for this device are not mstalled (Code 28)

These i no diives selected for the device information st of
element.

To find a drver foe ths device, chck Update Dives,

| UpdseDiver. |

[ ok || Cocel |

3. Especifica la ruta para el driver USB-Blaster:

En la ventana Update Driver Software window, click Browse my computer for device software



How do you want to search for driver software?

2 Search automatically for updated driver software
Windows will search your computer and the Internet for the Latest driver software
for your device, unless you've disabled this feature in your device installation
settings.

# Browse my computer for driver software
Locate and imstall driver software manually.

[ concat ]

4. Seleccién la versién apropiada para el driver USB-Blaster:

Encuentra el driver apropiado localizado en \<Quartus Il system directory>\drivers\usb-blaster.
Click OK y desde la ventana de retorno. Click Next para instalar el driver.



Browse for driver software on your computer

Search for driver software in this location:
 CAaltera\12.1\quartus\drivers\usb-blasted v [ Bowse. |

Include subfolders

2 Let me pick from a list of device drivers on my computer
This list will show installed driver software compatible with the device, and all driver
software in the same category as the device.




Sedect the folder that containg drivars for your hardware,

> B User .
48 Computer
o & Local Disk (C)
4 | 3lera
¢« 121
4 | quartus
4 | drivers
b 1386
> L sentinel
4 | usb-blaster
b
) B4
> b wsbeblaster-ii
> winr

Would you like to install this device software?

Name: Altera USB-Blaster Device Driver Package
T d Publisher: Delaware Altera Corporation

Always trust software from “Delaware Altera | install | | Don'tinstall |
Corporation”.

@ You should only install driver software from publishers you trust. How can | decide which
tevice sof i <afe to install?

5. El driver USB blaster estd listo para usarse.
El driver ya esta instalado. Click en Finish para comenzar a usar el DE2i-150.

6. Para confirmar la instalacidn, busca el Altera USB-Blaster bajo el Universal Serial Bus controllers
en el Device Manager.
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File Action View Help

< 2@ EE

A Computer Management (Local| « = WH-test-01

4 U] System Tools {8 Computer
(D) Task Scheduler Ca Disk drives
18] Event Viewer B2 Display adapters
22 Shared Folders o OVD/CD-ROM drives
& Local Users and Groups 05 Human Interface Devices
() Performance <& IDE ATA/ATAPI controllers
& Devace Manager — Keyboards

4 %% Stonge & Network adapters
&F Disk Managernert b Other devices

5y Services and Applications . ¥¥ Ports (COM & LPT)

B processors

& Sound, wdeo and game controllers

R Sstern devaces

- i Universal Serial Bus controllers
| @ ARera USB-Blaster

¢ Gk USBHes
Genenc USB Hub
Sandaed Enhanced PClto USB Host Controlier
Standard Enhanced PCI to USB Host Controller
USE Compostte Devace
USB Root Hub
USB Root Hub

«esese

3 INICIAR UN PROYECTO CON QUARTUS II

Lo primero que hay que hacer es iniciar un nuevo proyecto en Quartus Il. Un proyecto es un
conjunto de archivos que mantienen la informacién del disefio FPGA. El Quartus Il crea dos tipos
de archivos los (.gsf) y los (.qpf).

3.1 Asignando el dispositivo

1. En el software Quartus Il, select File > New Project Wizard. Se abre la pagina de introduccién.
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¢ New Project Wazard

Introduction

he New Project Wizard helba you Create & mew Srogect and Srelmeary praject settings, rduding he fallosng:
- Project name and dreciory

L Name of the pdevel desgn ety

L Progect fies and Rrares

L Target device famly and devce

L] EDA 00 setings

fou Can change e settngs for an exsting praject and soecfy addtonyl Droject-wide Setings wih e Setings command (Assgrments menu). You can use
e varous pages of the Setings Aalog bax 10 a3¢ functonaiity 12 The project.

(] Qon't shom me tha rroducton sgan

[coce |t )

2. Click Next.
3. Ingresa la siguiente informacidn acerca de tu proyecto:

a. What is the working directory for this project? Ingresa un directorio en el cual vas a ingresar los
archivos de tu proyecto del Quartus Il para este disefio.

b. Por ejemplo, E:\My_design\my_fpga.

c¢. Los nombres de archivos, nombres de proyectos y directorios del Quartus Il no pueden tener
espacios.

d. What is the name of this project? ingresa my_first_fpga.

e. What is the name of the top-level design entry for this project? Ingresa my_first_fpga.

12



t' New Project Wizaxd &

Directory, Name, Top-Level Entity [page 1 of 5]

What is the morking deectony for this progect?

EyMy_desgnimy_frst_foge

What is the name of $us praject?

my_frst_fogel

What is the name of S jop-devel desgn enty Sr $ag project? This name & case senetve and must exactly maich the entty mame n the desgn Sle.
my _frst_foce

[use Exstng Mresect Setangs...|

™
™
™

[[<tox [ ment> J[ mwn | cames ||

f. Click Next.

g. vas a asignar un dispositivo FPGA especifico al disefio y asignar pines.
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Wizazd

i New Project

Family & Device Settings [page 3 of 5]
Select the famly and device you want to target for complation,
Device famiy
Eamdy: Cyclone IV GX

Devees: (A
Target device

O 2 devece selecied by e Finer
(=) gpeckc devce slected r 'Avalable deaces’ lat

Qther: 0o
Ayadatie deves:

Nare Core VoRage LEs User 1/0s
PG IO IRT LN N 7
BPAOGXIS0FCT LV N0 4%
EPAOGX1S00FCE LV N0 4%
EPAOGXI1S00F2MT LV 1950

EP4CGX 15005308 & M0 S8
EP4CGX1S00F307 & N0 S08
<
Companon devwce
wrolop
o 5 B RAM L 00y GEVCE reSUICes

»w e .

hom n Avalable devices’ gt

Package: Anvy v
Pn gount: Ay v
Soged grade: Ay v
Name fter:
7] Show sdvarced devices Moo ompebie ory
‘Glltm()u-dm GXB Recewer (hanned PMA |
4 [
s :
8 1
8 1
,
& 1w
>
(<t J met> J| grwh || cocs || o |

h. Click Finish.

4. Escoge si para crear el directorio del proyecto my_first_fpga. Acabas de crear tu primer proyecto

FPGA en Quartus Il.

14



sartemx L1 J2-bat E:/ By dezsgo/my fanxt _fppn/my Cacxt_fpgn ay farxt _fpga
D Tt Jew Dumct Amgwerts Ppomsrg Jooe rdow ep &)
DSUHD & X @ « o v o

* QY /B T W HORT S ® L w

Promct Newgetor v x
e,
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Drovry | Brim | @ comprione

= s QUARTUS 11

Task OTme A n.
= P Comgle Desn
= P aoves A Setess
) £t servgs
| RESE
P 2 b S0
P Fanen wege v

X x Y v v

¥ Type Message

4 ENTRADA DE DISENO
4.1 Agregar una Mega Funcion PLL
Esta seccion describe como agregar una mega funcion PLL.

En el disefio de entrada creas un esquema o archivo de bloque de disefio (.bdf) este es el disefio
top-level. Agregaras funciones de librerias de médulos parame trizados (LPM) y asaras cédigo
Verilog HDL para agregar un bloque légico.

1. Escoge File > New > Block Diagram/Schematic File para crear un nuevo archivo Block1.bdf, el
cual guardaras como disefio top-level.

15



New Quartus II Project
(=) Design Files

AHDL File

EDIF File

Qsys System File
State Machine File
SystemVerilog HDL Fie
Td Script File

VHDL File

Verilog HDL File

=l Memory Files

Hexadecdmal (Intel-Format) File
Memory Initialization Fie

=} Verification/Debugging Fies
In-System Sources and Probes File

Logic Analyzer Interface Fie
SignalTap II Logic Analyzer File

(=} Other Files

AHDL Indude File

Block Symbol File

Chain Description File

Synopsys Design Constraints File
Text File

Block Diagram/Schematic Fie

2. Click OK.

3. Escoge File > Save se guarda tal como indica la informacion siguiente.

Help

* File name: my_first_fpga

* Save as type: Block Diagram/Schematic File (*.bdf)

4. Click Save. El nuevo archivo de disefio aparece en el bloque editor.




ay fagat _fpgn

11 J2-bat Ez/By dexsgoSmy facat _fpyn/my facxt_fpga
DCSUO & 1@ « & m oo Yy HY /P9I TSPV DO S LuwD
Promct Nevgesy o x S my_frwe_oge bt [ o
., B RROASL-012ANNN0ON 05 =6
&) e v ox B CCH INTPIN? -~

.-._bﬁ_h—&
£ 3
Dreyry Brm | & owgrom
Tooka o ax
Pgw Corplatar v |Csomce |
e OTme A
w B Comple Cesgy
» P aoves Aivten
s 2727
| e
P Aolvos b Bator ston
& P Pavson Mepe v
< 2 < >
x x v
5 Y
© Tipe Message
im:—_/\:::u\m--‘-/\_w \erey N\ e Serve oo N Sqwemet N\ R J
421 0% 000080

5. Agrega codigo HDL al blank block diagram al escoger File > New > Verilog HDL File.
6. Click OK para crear un nuevo archivo Verilogl.v, el cual guardaras como simple_counter.v.
7. Selecciona File > Save como se indica a continuacién:

* File name: simple_counter.v

* Save as type: Verilog HDL File (*.v, *.vlg, *.verilog)
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El archivo vacio resultante esta listo para que le sea ingresado el cddigo Verilog HDL.

8. Teclea el siguiente cédigo en Verilog HDL en el archivo vacio simple_counter.v

//It has a single clock input and a 32-bit output port
module simple_counter (

CLOCK_50,

counter_out

);

input CLOCK_50;

output [31:0] counter_out;

reg [31:0] counter_out;

always @ (posedge CLOCK_50) // on positive clock edge
begin

counter_out <= #1 counter_out + 1;// increment counter
end

endmodule // end of module counter
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9. Guarda el archivo al escoger File > Save, precionando Ctrl + s, o al dar click en el icono del floppy
disk.

10. Escoge File > Create/Update > Create Symbol Files for Current File to convert the
simple_counter.v file to a Symbol File (.sym). Veras este archivo simbolo para agregar el cédigo HDL
a tu BDF schematic.

El software Quartus crea un archivo simbolo y despliega un mensaje.

& Quartus II @

i ) Create Symbol File was successful

OK

11. Click OK.

12. Para agregar el simbolo simple_counter.v al disefio top-level, click el my_first_fpga tab.
13. Escoge Edit > Insert Symbol.

14. Double-click el directorio del proyecto para expandirlo.

Incluso puedes dar doble_click en un area vacia del BDF para abrir el Symbol dialog box
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16. Click OK.

17. Mueve el cursor hacia el BDF grid; la imagen simbolo se mueve con el cursor. Click para colocar
el simbolo simple_counter en el BDF. Puedes mover el bloque después de colocarlo al dar un
simple click y arrastrarlo hacia donde tu quieras al soltar el botén del mouse.
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18. Presiona la tecla Esc o click en un logar vacio en el esquema grid para cancelar.
19. Guarda regularmente tu proyecto.
Usando Quartus para agregar un PLL Mega Funcion

Mega Funciones, tal y como las disponibles en el LPM, son mdédulos pre-disefiados que puedes
usar en el disefio FPGA. Estas mega funciones Altera son optimizadas por velocidad, area y familia
de dispositivos.

Puedes agregar eficiencia al usar una mega funcion en lugar de escribir la funcién ti mismo. Altera
incluso provee funciones mas complejas, llamadas funciones MegaCore, las cuales puedes
adquirirlas gratis pero requiere una licencia para usar en el disefio de alguin producto. Este disefio
tutorial usa un reloj PLL para dirigir un contador simple. Un PLL usa el on-board oscillator para
crear una frecuencia de reloj constante como ingreso al contador. Para crear el reloj, vas a agregar
una mega funcion LPM pre construida llamada ALTPLL.

1. Escoge Edit > Insert Symbol o click Add Symbol on the toolbar---

2. Click Megawizard plug-in Manager. The MegaWizard Plug-in Manager aparece.

¢ NegaVizard Plug-In Nanager [page 1] @

The MegaWizard Plug-in Manager helps you create or modfy design fles that contan custom variatons of
megaf L

\ Which action do you mant to perform?
® iQtC!t 3 new Custonm megafunction varation

(O gdt an existing custom megafunction varaton
O Cogy an existing austom megafunction variaton

Copyright (C) 1951-2012 Alters Corporation

Cancel X Next > |

3. Click Next.
4. En MegaWizard Plug-in Manager [pagina 2a], especifica las siguientes secciones.

a. Escoge I/O > ALTPLL.
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b. Under which device family will you be using? Escoge the Cyclone IV GX para la tarjeta DE2i-150.

¢. Under Which type of output file do you want to create? Escoge Verilog HDL.

d. Under What name do you want for the output file? Escribe pll al final del directorio ya creado.

e. Click Next.

¢ NMega¥Wizard Plug-In Ranager [page 2al

Which megafinction would you ke 1o customize?
Select a megafunction from the kst below

A

N\ ) ~
TQOALTGX
T ALTGX_RECONFIG
T ALTINT_OSC
T ALTIOBUF
QL ALMLVDS_RX
TLOALTLVOS MY
TR ALTMEMPMY
\ ALTOCT
QAL
*Q ALTRLL_RECONFIG
T ALTREMOTE_LPDATE
X ALTTEMP_SBNEE
\ AR
\ "ty
\ MNieraF 1< v

Which device famlly sl you be using?  Cydone IV GX v

Which type of output fle do you want to create?

O s

O poc

© veriog HOL

What name do you want for the gutput Sie?

£: My _designjmy_frst_foga/pl. v @
Output fies wil be generated using the dassic fle struchure

[] Return to this page for another create operation

Note: To comple a project successfully n the Quartus [ software, your design
fles must be In the project drectory, n a lbrary specfied n the Librares page of

the Opbtions dalog box (Tools menu), or a lbrary specfied in the Libraries page
of the Setangs dalog box (Assignments menu).

Your current user lbrary directories are!

[ comcel J[ <gsx J[ vem> |

5. En la ventana del Manager del MegaWizard Plug-In [pagina 3 fe 14], crea las siguientes

secciones.

a. Confirma que la opcidn de la familia del dispositivo seleccionado muestre el dispositivo que
corresponde a la tarjeta que estas usando.

b. Escoge 6 en el grado de velocidad para DE2i-150.

c. Ingresa 50 MHz. a la frecuencia del inclockO.

d. Click Next.
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NegaVizard Plug-In Bannger lpnge 3 of 14)

Winch device speed grade wil you De usng?

M LYy temOer AN e r Qe Oenies ity

What & he freguercy of e inckd rput? 0. 000l Mz

Set up PLL I VDS mode Dota rate: Mot Avadabie Mo
AL Type
Wiich 2L type wll you be uang?

Past P Erbances P (5) Select the PLL hype sutomatcaly
Operaton Mode
How ol he PLL outputs De pererated?
(2 Use the foedback path nsde he PLL

(& 1 rermal mode

© 3 source-synchronous compensaon Mode
© 3 2000 delay buffer mode
Comnect Bhe fmwm port Padeecsonsl)
Wt ro compersaton
Create an Tow' rput for an external feedback (External Feedback Mode)

Which output clock wil be compersated for? D ¥

[[comcnt |[ <mock || tiwt> |[ mown |

6. Apaga todas las opciones en el MegaWizard pagina 4. Cunado las estés apagando, los pines
desapareceran del bloque PLL.



¥

Nega¥izard Plug-In Nanager lpage 4 of 14)

& ALTPLL

Able 3 mplement the reguested PLL

Optonal Inputs
Create an plera’ nout 1 seletively enable the AL
[[] Crese an 'srese? rout 1o asyncdvorcudy reset e ML
[] Create an pfdera’ rput % selectvely enable the shase Fequercy detector

Lock Oupat
[ Creane Yodked sutpus
[[] Enatie seif reset on koss lock

Advanced Paramesers
LUsing these parametars & recommended for advanced users only
[7] Creane outpas flels) usng he Advanced AL parameters

« Configuratiorn with ouut dock{s) thet wae cascade countiers ane not supported

[[Conces | [ <Box || test> || b |

7. Click Next cuatro veces mas, en el la ventana del MegaWizard Plug-in Manager [page 8 of 14],
has las siguientes selecciones.

Clock Divisidn Settings input 10
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NegaVixard FPlug-In Banager [page B of 14)

Able 12 mplevert e reduested AL

[¥] Use s dock
Clock Tap Setangs

© Erver ouspt dack Seguency:

@ Erter output dock parameters:
Clock muisphcation factor
Clock dvison factor

Clock ghase shit

Clock auty cyde (W)

Note: The dsplayed nienal setings of Pe
PUL 5 recommended Sor use by advanced
users only

c0 - Core/External Output Clock

Reguested Settngs AN Settrgs
10000000000 My $.200000
. - .
H . 1
0 : <‘C”' W
0.00 — 0.00
.00 H 9.0
Cescrptor oh A
Prmary dock vOO frequercy Do) ) '
Modubs for M courter 2 =
PR >
Per Cock Feastiety Indcators
[

[Comcet || <tack || tyt> || orwh |

9. Click Next.

10. El wizard despliega un sumario de los archivos creados. Click Finish.
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BogaVWizard Plug-In Bxnager [page 14 of 4]

aly gererated, ard &

Tarm on the fles you wish 12 generate. A gray thedkmark indh afetatn

Peddox 5 mantaned N soceguent MegaVawd PLG-In Manager sespons.
The MegaWizard Pug-3n Manager Ceates S selected Sles n Se Slowng drectory:

£y _desgnmy_firat_foos),
Fie Descrption

b varwson Se

ol oo rtarrer cor's 9% Se
Do AOL Incude fle
Ootove VHOL Comporent cecy aton fie
ot _rme v rantaton tevoete fie
ol ro.v Veriog HOL black b fle

green thedomark NaCates an 0otondl fle. Ok Frsh 10 generate e selected fles. The state of each

La ventana simbolo aparece, mostrando la nueva megafuncion PLL creada.
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Laundh MegaWizard Mug
| Meguiizard Pug-in Marager .. |

Lo J[ comce |

11. Click OK y coloca el simbolo pll dentro del BDF hacia la izquierda del simbolo del
simple_counter. Puedes mover los simbolos al rededor al presionar el botén izquierdo del raton.
Ayuddndote a asegurarte de que se hayan alineado correctamente.

f Quastux L1 32-bat E:/By dexsgo/my facxt fpgwny facxt _fpgn ay facxt_fpgn
D DIt Yow Dumd Awgwerts Moy lwk D b O @
DSHO & L@ v v wy v vy HY /OO TP DO S Y LeD®
L 0% B winboer O © e cowens >
- B RA0OACL-02AXNNNOOND B/as - @
&) Cydore tvox P IXTPILY -
'--_Qn_w-‘
« > 2
Drovey | Bre | @ i oy _ = ,
— { - -——5 4 .- prm——
Tads A x -w - ) ) r
- o R0 O T RO
| s |EEEEES L
Toa S Tre & e '
w B Comple Dengn
» P vovsbieten

) £ot Serwgs

--o—iq‘u‘

P ravas & Babor st - -
£ » < >
x v
- =
@ Iype Messege -

. b Quartas eate . . =
£5 2
;ng. romrs (0 N\ Save s A\ 3k (4 /| sy /| el mevey /| Sve /| Soesed [\ Py /

e we ol e bme - w e ococcs

12. Mueve el ratdn de manera que el cursor este sobre el simbolo pll cO output pin. El icono de la
herramienta del nodo ortogonal aparece.
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13. Click y arrastra un bus line desde el cO output hacia el simple_counter clock input. Esta accidn
ata la salida del pll a la entrada del simple_counter.

pll

inckO ) L 0

14. Agrega un pin de entrada y un bus de salida con los siguientes pasos:
a. Escoge Edit > Insert Symbol.

b. Under Libraries, select quartus/libraries > primitives > pin > input.

c. Click OK

Si necesitas mas espacio para colocar simbolos, puedes usar la barra horizontal y vertical a las
orillas de la ventana BDF.

2 Symbol

\branies:
= & ofitera/L2.0/uanusrares/ A
+ O megatrinors
# O oters
" © prmesves
& O buffer
& O oye
® O oter
» ©pn
Q biar

] o
O output e T Co——

O

[ MegswuardPuginMaege.. |

Lo J[ coce )

d. coloca el nuevo pin dentro del BDF de manera que este tocando la entrada del simbolo pll.

e. Utiliza el mouse para dar click y arrastrar la nueva salida hacia la izquierda.
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f. Cambia el nombre del pin al hacer doble click en pin_name y teclear CLOCK_50 este nombre se
relaciona con el reloj oscilador que estd conectado a el FPGA.

g. Usando el Orthogonal Bus tool, dibuja una linea de bus conectado en un lado de la salida del
simple_counter, y deja el otro extremo desconectado por 4 a 8 grid espacios hacia la derecha del
simple_counter.

B Pin Properties EJ

General Format

To areate multiple pins, enter 3 name in AHOL bus notation
(For example: “name[3..0]"), or enter a comma-seperated kst of names.

Pn name(s): cLock_sf

Default value: |VWCC v

Lok J[ concs |[ ko |

h. Click derecho en la nueva linea de salida y escoge propierties.

i. Usando el Orthogonal Bus tool, dibuja una linea de bus conectada a un lado de la salida del
simple_spunter, y deja el otro extremo desconectado de 6 a 8 grid espacios hacia la derecha del
simple_counter.

j. Escribe contador [31..0] como un nombre de bus. La notacidn [X..Y] es el método que utiliza

29



Quartus Il para especificar el bus con esquemas BDF, donde X es el bit mas significativo (MSB) y Y
es el menos significativo (LSB).

k. Click OK

Bus Properties @

General Il’ont | Fornat |

Name: |counter(31..0]

[~ Hide name n block design file

W= BiH
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4.2 Agregar Un Multiplexor

Este disefio utiliza un multiplexor para enrutar la salida del simple_counter hacia los pines del LED
en la tarjeta DE2i-150. Vas a usar el MegaWizard Plug-In manager para agregar un multiplexor,
Ipm_mux. El disefio de multiplexores tiene dos variaciones del bus contador a cuatro LEDs en la
tarjeta DE2i-150.

1. Escoge Edit > Insert Symbol.

2. Click MegaWizard Plug-in Manager.

3. Click Next.

4. Escoger Installed Plug-Ins > Gates > LPM_MUX.

5. Escoger la familia del dispositivo que corresponde al dispositivo en la tarjeta que estas usando,
escoge Verilog HDL como el tipo de archivo de salida, y nombra el archivo de salida como
counter_bus_mux.v.

6. Click Next.
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' MegaV¥izard Plug-In Nanager

[page 2al

Which megafunction would you ke to customize?

-

B8

o

BB

Select a megafunction from the st below

= B Instaled Plg-ins

7 Altera SOPC Buider

() Avithwmetic

) Commuricatons

Coe

) Gates
TQ M _QSHIFT
T LPM_CONSTANT
T LPM_DECOOE
L LPM_MUK

- )

) mterfaces

) JTAG-accessbie Extersions

() Memory Compler

] Cick to Open 1P MegaStore

~A

Which device famly will you be using? Cydone IV GX v
Which type of cutput file do you want to create?

O o

O pox

® veriog 0L

What name do you want for the gutput file?
E: My _designjmy_frst_fogajcounter bus_mux.v
Output files wil be generated using the dassic fle structure

(=)

[[] Retum 1o this page for another create cperation

Note: To compie a project successfully in the Quartus IT software, your design
fles must be n the project drectory, in a Rrary specified in the Lidranies page of
the OpSiors dalog box (Toolks meny), or & Brary specified n the Libraces page
of the Settings dalog box (Assgrments menu).

Your Current user ibrary dreciones are:

[ conce |[ <gock || mest> |

Freh

7. Under How many 'data’ inputs do you want? Selecciona 2 entradas (default).

8. Under how 'wide' should the data input and result output be? Selecciona 4
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Nega¥izard Plug-In Nanager [page 3 of 5]

Resource Usage

Currently selected device famlly: ¢ ore 1y GX

How many ‘data’ Inputs do you want? 2

How wide should the 'data’ input and 4
the 'result’ output buses be?

Do you want to pipeine the multiplexer?

® No

O Yes, 1 want an output latency of | 1
Create an asynchronous Cear input

Create 2 Cock Enable nput

[¥] Match project/default
v
v bits

dock cydes

1 lpm_mux

[ cancel || <gack || mext> || Ersh |

9. Click Next.

10. Click Finish dos veces. La ventana del simbolo aparece.
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o 0 cfatera/12.0/quertus Moranes.

counter_Bus_mux

.....

dats 13 Ol Jp—
aaadxl O i ld
Satalxdd O

2 1 -

(-]
[7] Repeat-nsert mode
[7] prmert symbol as Slock

[ mecewizard Pug-tn Manager... ]

11. Click OK

12. Coloca el simbolo del counter_bus_mux bajo los simbolos existentes en el BDF.

counter bus_mux

resutf} O

13. Agrega buses de entrada y pines de salida para el simbolo counter_bus_mux como se muestra
a continuacioén:

a. Usando el Orthogonal Bus tool, dibuja lineas de bus del datalx[3..0] y datax0][3..0]
Los puertos de entrada de 8 a 12 grid espacios hacia la izquierda del counter_bus_mux.

b. Dibuja una linea de bus de la salida resultante del puerto [3..0] de 4 a 8 grid espacién hacia la
derecha del conunter_bus_mux.

c. Click derecho en la linea de bus conectada a datalx[3..0] y escoge propiedades.

d. Nombra el bus counter[26..23], el cual selecciona solo aquellos counter output bits para
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conectar los cuatro bits de la datalx input.

Debido a que los buses de entradas al counter_bus_mux tienen los mismos nombres que el bus de
salida de simple_counter, (counter([x..y]) el software del Quartus Il sabe conectar estos buses.

e. Cick OK

f. Click derecho en la linea del bus conectada a data0x[3..0] y escoge propiedades.

g. Nombre los buses counter[24..21], de los cuales selecciona solo los bits de las salidas para
conectar a los cuatro bits de entrada del datalx.

counter_bus_mux

. W result{3. C;:

h. Click OK

e eee.. countedd® 23 D 0.0 D0. datatxf2 0
...... ”.:c ntegld..< e e

....... ”

gatadx[3. 0] j

Si no lo has hecho ya, guarda el proyecto antes de continuar.

14. Escoge Edit > Insert Symbol

15. Bajo las librerias, doble click quartus/libraries/> primitives > pin > output

[ Megewasd Pugin Manager...

L= I

Corcel |

16. Click OK
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17. Coloca pin de salida de manera que se conecte al resultado de la linea del bus
counter_bus_mux [3..0].

18. Renombra el pin de salida como LEDG [3..0] como se describe en el paso 13 cy d.

counter_bus_mux - oo

catatz. 0 nPc.,IIﬁ‘;ﬁ:ﬁ'ﬁ__.If__ifﬁiﬁIIIﬁIIIIIIIIIIIII """"

sultf3. 0y - - rswE By D T L

data0x[3..0]| _ - . O W9
> I

nst? 1’ L

19. Coloca un pin de salida a la linea de seleccién multiplexor usando un pin de salida:
a. Escoge Edit > Insert Symbol.

b. Bajo las librerias, doble click en quartus/libraries/ > primitives > pin > input.

c. Click OK.

20. Coloca este pin de salida bajo counter_bus_mux.

21. Conecta el pin de salida al pin del counter_bus_mux sel.

22. Renombra el pin de salida como KEY [0].

pt
e
T - cas "l tepe : L———- - ‘—;“
[En Toudin aToC A
Laadovsl so0 [2o] ;

counter bus mux

"~,..v\ 0 — < h
— s T A ™ ¢ "Rl N
esutt) O s — LD

Has terminado de agregar los simbolos a tu disefio.
4.3 Asignar los pines.

En esta seccidn vas a asignar los pines. Antes de asignar los pines, realiza los siguientes pasos.
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1. Escoge Processing > Start > Start Analysis & Elaboration in preparation for assigning pin
locations.

2. Click OK en la ventana de mensaje que aparece después del andlisis y elaboracién completados.

Para hacer las asignacién de pines que se relaciona con KEY [0] y CLOCK_50 input pins y LEDG[3..0]
output pin, realiza los siguientes pasos.

1. Escoge Assignments > Pins, donde se abre el Pin Planner, una tabla spreadsheet-like de pines
especificos. El planeador de pines muestra el disefio de seis pines.

‘C?l'ln Flasner E: /By dezign/ay first fppa/my farst fpea ny farxt fpea ﬁ
fe £ Yew Proceswyg Joods Wndow e B .
Yashs e x - S e
@® - .
o J ExlyPn A . -
@ : Cree - - N
» ‘ ] ) -
-
@k X Named: * V[:q Bt X Fiter: Prs: o v
o™ g Node Nave Dwecton Lacaton LO Baw VREF Growp 1O Standerd Reserved =
Rk o 2.5V (detaur)
B o 2.5V [Sefa)
o OQutput 2.5V [detaux)
Outoust 2.5V (Sefai®)
‘ OQutput 2.5V (detaur)
Outpust 2.5V [Sefau) v
F >
% 002000

2. En la locacién de la columna junto a cada uno delos nombres de los nodos, agrega las
coordenadas.

Pin Name FPGA Pin Location
KEY[O] AA26

LEDG([3] F26

LEDG[2] F27

LEDG[1] AB25

LEDG[0] AA25

CLOCK_50 AJl6

Doble click en Location column para cualquiera de los seis pines para abrir una lista y escribir la
locacidn mostrada en la tabla, puedes seleccionar el pin de una lista. Por ejemplo, si presionas F1y
presionas la tecla enter, el Quartus Il rellena toda la locacién PIN_F1 por ti. El software mantiene
un seguimiento de los datos del FPGA correspondientes asi como el banco I/O y el grupo VREF.
Cada banco tiene un color distinto, el cual corresponde a lazo dibujado en la parte superior de la
ventana.
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Y Pin Planner E:/Ry_design/ay first _fpga/ny first_fpga ay ficrar _fpga

Ble Edt Vew Pucessng Toods Wndow tep @ (<]
':’ Tacks . vEx s CE—u
= ) Eatyon A . -
@|  Dow :
I{ < >
G{ : Named: * v@hﬂ: K PRAALS Fiter: P ol ~
o o Node Nare Dwection Lacaton 1O Dok RIF Growp 1/0 Standard Regerved A
w W Qoo 0 o PN AN 4 B4 N2 2.5V (gefaut)
A e o PON_AAXS 5 8 2 2.5V {defadt)
- < UG Outpt PN 6 D60 2.5V (efait)
< Le0a[ Output ON_F2Y 6 85 W0 2.5V [Sefadt)
= £ < uma(1] Output NS 5 52 25V (gefait)
£ < LEDO Outpunt PIN_AA2S S as_m 2.5V {Sefadt) v
3 T < >
% Q00000

Ahora, has terminado de crear tu disefio en Quartus Il.
4.4 Crea un archivo TimeQuest SDC default

La sincronizacién es importante para un disefio exitoso. Para este tutorial vas a crear un archivo
Sypnopsys Design Constraints basico (.sdc) que el Quartus Il TimeQuest Timing Analyzer usa
durante el compilado del disefio. Para disefios mas complejos, necesitaras considerar los
requerimientos de sincronizacion.

Para crear un SDC, realiza los siguientes pasos:

1. Abre el TimeQuest Timing Analyzer seleccionando Tools > TimeQuest Timing Analyzer.
2. Selecciona File > New SDC file. El SDC editor se abrira.

3. Escribe el siguiente cédigo en el editor:

create_clock -name "CLOCK_50" -period 20.000ns [get_ports {CLOCK_50}]
derive_pll_clocks
derive_clock_uncertainty

4. Guarda este archivo como my_first_fpga.sdc

38



¢ Quartes 11 D7t Fi/By desro/my Tivst Toan/ny fhest foen oy Tarst foen

B G gew PO Mepwents Maissseg s voe o T .
DPEHO S r @ v« mimon v HY /PO L PV OO XN B ® LeD
Pruect Navgatr vex t ——— oy - i_\--._\-u_\v‘." 6 m v ook O
BALT X 4B3AIRR I D lw | —~-39F
o - P M0E : TeATe Clock L .. ts (get posta (CLOCK
S [e—— 3 Sezrive pll clocks
- 3 derive clock uacertaist
- °
S $
* T e
I -
< »
& e B fs & Desgn Unis
Tasen vEx
o= e ¥ | Customuse. .. |
Tk an
»
»
T e Sevre
BB ot
» v
< > g .
X xY v
4
¥V Type Nerzage P
‘I
~
e 4 .
g'\..:m..'._s--—-« 130 A B bl A\ bl (106 N\ saewe (3 A\ Cocs s (3 N\ Ever /\ Sooened (6 A Sag /
F <
LAY X )

Nombrando el SDC con el mismo nombre que el archivo a excepcion de la extension .sdc causa que
el Quartus Il utilice el andlisis de sincronizacién por default. Si necesitas otro nombre, necesitaras
agregar el SDC a la lista de asignaciones de archivos.

5 COMPILA Y VERIFICA TU DISENO

Después de crear tu disefio debes compilarlo. La compilacidon convierte el disefio es bitstream que
puede ser descargado en el FPGA. La salida mas importante de la compilacién es el archivo objeto
SRAM (.sof), el cual se utiliza para programas el dispositivo. Ademas el software genera los
reportes que proveen informacidn acerca del cédigo que se esta compilando.

5.1 Compila tu disefio

Si quieres guardar el .SOF en la memoria del dispositivo, debes primero convertir el SOF al tipo de
archivo para al dispositivo de memoria.

Ahora que has creado un proyecto de Quartus Il completo e ingresado todas las asignaciones,
puedes compilar el disefio.

En el menu de proceso, escoge Start Compilation o click el botdn Play en la barra de herramientas.
Si se te pide guardar los cambios a tu BDF, click YES.

Mientras se compila tu disefio, el Quartus Il provee informacion util acerca de la compilacion.
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Cuando la compilacién este completa, el Quartus Il despliega un mensaje. Click OK para cerrar el

mensaje.

La ventana del Quartus Il despliega muchos mensajes durante la compilacién. No deberia
desplegar ninglin mensaje critico; deberia desplegar algunas advertencias que indicaran que la
sincronizacion del dispositivo es preliminar o que algunos parametros de entrada/salida de los
pines usados para los LEDs no fueron usados. El software provee los resultados de compilacién en

el reporte de compilacidn.

Flow Sumenary

Flow Status
Quartus &1 1252 Verson
Revaon Name
Top-evel Dntity Name
Famiy
Dewvice
Tining Models
= Tots logc clements

Total combiratonal £nctons

Dedcated loQc repsters
Total regsters
Total pins
Totsl vl prs
Total memory bits
Dmbedded Mutpler 5-bit elements
Tetal GxB Recever Charvel PCS
Totsl GXB Recewver Channel PMA
Total Gx8 Tranamtter Oharnel ICS
Totsl GXB Transmitter Channel PMA
Total PLLs

Successiu - Fri Aug 17 125225 2012
12,0 B 232 0705/2012 5 1 5 Al Version
oy _fest_foge

my_frst_foge

Cydone Iv GX

EPACGX1500F31CT

Fral

31/195,7%0(<1%)
31/199,%0(<1%)
27/1969,7%0(<1%)

o

6/508(1%)

0

0/6/635520(0%)

0/720(0%)

0/8(0%)

0/8(0%)

0/8(0%)

0/8(0%)

1/8(13%)

5.2 Programa el dispositivo FPGA
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Después de compilar y verificar tu disefio estds listo para programar el FPGA en la tarjeta.

Descargas el SOF que acabas de crear en el FPGA usando el circuito USB-Blaster en la tarjeta.
Prepara tu hardware para programar siguiendo los siguientes pasos:

a) Conecta la fuente de poder a la tarjeta y a un enchufe.

b) Para la tarjeta DE2i-150, conecta la USB-Blaster al j9 y el cable USB al USB-Blaster. Conectado al
otro extremo del cable USB a la computadora huésped.

c) Enciende la tarjeta usando al switch on/off.

Programa el FPGA siguiendo los siguientes pasos.

1. Escoge Tools > Programmer. La ventana del programador se abre.

D Progrannet E:/Ry_design/ay ficat_fpga/ay first _fpga ay facat_fpgn [ny first _fpg.
Fle Eot Yew PFrocessng Tooks Wedow Hep B e
o Mardware Setp...| LS8 Saster JUS8.0) Mode: ITAG v mgu:[ ]

[7] Erabie real-tme 159 % allow badkgraund programming (for MAX [T and MAX V devices)

- . Fle Deve Chedksum Usercode Program/ Verty
Phswr | Corfgure

’ wy_fext_foon.sof SN 1Y0F 31 00T0ES presrpes (2]

Examine

4

— !

2. Click Hardware Setup.

3. Si aun no esta encendido, asciende la opcion USB-Blaster [USB.0] bajo el actual hardware
seleccionado.
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X

D Hardware Setup

Hardware Settings . JTAG Settings

Select a programming hardware setup to use when programming devices. This programming
hardware setup apples only to the current programmer window.

Curenty seected hardvere: (g Vs A |

Availlable hardware items

Harcware Server Port [ Add Hardware... ]
USB-Elaster Local use-0 R
REMOoV rdware

4., Clcik Close.

5. Si el archivo en el programador no muestra my_first_fpga.sof, click agregar archivo.

6. Selecciona el archivo my_first_fpga.sof del directorio del proyecto.
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D Programmer E: /Ry dogign/my faret fpea/my farst fpea ny farst fpga [my faret fpe... KE&

Dle [t Yew Processng ook fedow b ) Q@

&, Hardware Seto...| [USD Baster [US8-0) Mode: |ITAG v progess: | ma:-ﬂj

(7] Enabie res-teme 159 1 slow badkground programeg (for MAX [T and MAX ¥ devices)

Fle Dewve Chedkaum Usercode Prograr/ verfy Slark Exarwe

i

Stat

o v PPACGX L S00F 3 ) 0 AAAAAAAD

Ao Detect

Y
«,55_53 ?i(
A HENHIHIE

— .

5.3 Verifica el hardware

Cuando verificas el disefio en hardware, observas el comportamiento del tiempo de ejecucion del
disefio del hardware FPGA vy te aseguras de que esté funcionando apropiadamente.

Verifica el disefio siguiendo los siguientes pasos:

1. Observa que los cuatro LEDs de la tarjeta aparentas estar avanzando lentamente en un patrén
de cuenta binaria, el cual esta controlado por los bits del simple_counter [26..23].

Los LEDs tienen baja actividad, por eso, cuando la cuenta comienza todos los LEDs son encendidos.

2. Mantén presionado KEY [0] en la tarjeta y observa que los LEDs avanzan mas rapido.
Presionando KEY causa la multiplexion del disefio usando la parte mas rapida del counter.

3. Escoge Assignments > Device. Click Device and Options.
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* Device

Select the family and device you mant 1o trget for complasen.

Devvce famly Show in "Avalable devces’ Ist
Eamnly: | Cyciore IV GX v Package: Arvy ~
Devices: (Al Pn gount: Arvy -
Soged grade: Any e
Target device
Name fiter:

O Auto device selected by the Fitter
(3) Spechc devce selected in Avalabie devices' kst

Qther: n/a

[¥] show sdvarced devces  HaxdCopy compatble only

Agalable devces:
Core Voltage s User 1/0s GXB Tramsmitter Channel PMA GXB Receiver Chan * |
lar—vwerverr-vwer—ere —— i .. - .
|EPSCGX1100F31C8 1.2V 109424 508 8 8
(EPSCGX1200A3117 1.2v 105424 %08 s L]
[EPACGSOFIXT 1. 20 19970 287 4 a
|EPACGN1S0CFIXCH 1. 2¥ 199760 287 4 3
[EPACCXISOCFINT L. v 19900 87 4 4
iEP(f.\'.w.‘K7 LN 199060 425 8 8
19(@:@5:7@ LN 19060 4% 8 8
|EPACGXLSIOF27T7 1.2 149760 426 3 )
EP40GX LSO0F 31C 02 8 8
|EPSCGXLSOOFIICE 1.2V 19990 S0& 8 8
lEP(G\'.SUJ‘JI:? LN 199760 S08 a 8 v
< . >
Mgration compatbiity Compenon device
[ Moraton Dewces... ] MardCopy
0 migration devices selected Lt D59 & RAM 10 Hr dCopy device resources

)

Lox J[ comad [ neo

J

Escoge pines sin usar. Reserva todos los pines no utilizados: Escoge la opcidon As input tri-state.
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¢ Device and Pin Options ay firat_fpga

s
Configuranon
Programmeg Fles Soecfy devce-wide options S reserving ol unused prs on the device, To reserve ndhvicusl dual-
Unused Pns DuUrpose configuration pins, 9o 10 the Dual- Purpose Pns tab. To reserve other pins Indvidualy, use
Dusi-Purpose Prs Te Assgrment Edaor.
Capactive Loadng
g draniiang Reserve al yrsed ors: v
Voltage
P Placement
Errer Detecton CRC
C\P Setargs
Descption:
Reserves al unused prs on the target device n one of S stales: a3 rputs hat are isiated, &
outputs Bt drve grourd, a8 cutputs Bt Grve a0 urepecfied soral, a8 rput teetated with bus-
hold, or 85 nput T-stated with mesk pull<p,
o J[ concd J| no |

Has doble click en OK.
4. En el menu de proceso, escoge Start compilation. Después de la compilacidn, Escoge Tools >

Programmer. Selecciona el archivo my_first_fpga.sof del directorio del proyecto. Click Start. Para
entonces podras notar en los otros LEDs apagados.
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